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Overview
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About LS-PrePost

= LS-PrePost is an advanced pre and post-processor
designed specifically for LS-DYNA

= LS-PrePost is developed for Windows and Linux
= LS-PrePost is Free

= Core Functionality
e Full support of LS-DYNA keyword files
* Full support of LS-DYNA results files
* Robust handling of geometry data (new CAD engine)
* Pre-processing (meshing, model clean-up, entity creation)
e Post-processing (animation, fringe plotting, curve plotting)
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Online Resources

= QOfficial Website
e http://www.lstc.com/Ispp

= User Group
e http://groups.google.com/group/ls-prepost

= |Latest Release Version:
e http://ftp.Istc.com/anonymous/outgoing/Isprepost/4.2/

e ftp://ftp.Istc.com/outgoing/Isprepost/4.2/

= Beta Version:
e http://ftp.Istc.com/anonymous/outgoing/Isprepost/4.3

= Training notes:
e http://ftp.Istc.com/anonymous/outgoing/qyan/Training/Intro/
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Workshop 1

General Operations

< Parts on/off

< Render buttons (bottom toolbar)
< Group, appearance and view

< |dentify and find

< Element blank(mask)

< Part color
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Workshop 1

Load and view an LS-DYNA Keyword file...
Launch a new session of LS-PrePost

File > Open > LS-DYNA Keyword File
(select /workshop1/belted.k)

Use Shift + Left Click to rotate the model

Click render buttons @ — @

O, ®

% @\ﬁw B 9 O & @ @ @ .V |[w & p @ @

Opti  HidEle ieEle WirEle Feat Edge  Grid Mesh  Shrink Section Frin Unref ||EdgGeo|ShaGeo WirGeo | ShfCtr Clear AutCen Zoln  ZoOut

© OO GG
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Use the part on/off interface...

Workshop 1 (continued...)

)

Assembly and Select Part 28
= Go to Model = SelPart (“Assembly and Select Part ”) and | Assembly | GPart | Part |
T . +|[1 psoLID 1
select individual parts from the list > PeOLID )
. . 3 PSOLID 1
= Use Ctrl + Left Click to select multiple parts 4 PSOLID 1|2
. . 5 PSOLID 1
= Click All to display all parts 6 PSOLID 1
. . 7PSOLID : 1
= Toggle Beam / Shell / Solid / Disc / Sbelt 8 PSOLID 1
9pSOLID : 1
= Click SortBy button and turn on/off some check boxes in 10 PSOLID 1
. . . 11 PSOLID 1
the setting columns in the Part Sort dialog 12 PSOLID 1
) 13 PSHELL : 1
= Click the MatTypeName header to see the sorting effect Rsurf 17PSOLID : 1
Sphnd 18 PSHELL - 1
Fluid(Ale) |19 PSHELL : 1
Nurbs 20PSOLID : 1
: 21 PSHELL : 1
2 PartS DISShPere o) psHELL + 1
Sort Partw InputOrder /|24 PSHELL : 1
25 PSOLID 1
Matld MatName MatTypeName | Eosld | Hrglass | Elfor  Setting Column: [ selected 26 PSHELL : 1
1 1 006 VISCOELASTIC 0 0 v Type List CNRBs |27 PSOLID 1
2 36 006 VISCOELASTI( 1] 0 _| |+ partd el Type >:| l Info " SortByk 3
3 86 009 NULL 0 0 ~ v Partliame 7N
4 88 009 NULL 0 0 v Soctionkd ( 1\' Al “ None "
el 2 020 RIGID 0 0 [ SectionName T[/ Auto “ Apply “ Restore
6 3 020 RIGID ] ] ¥ Matid
7 4 020 RIGID 0 0 | -5
8 5 020 RIGID o o [+ MatHame \ﬂj
9 6 020 RIGID o o [+ MatTypeName
10 ri 020 BIGID (1] (1] —
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Create a part group...
= Go to Model - Groups

=  Click Create (all visible parts will be saved to “Group_43")

= Select “SetP94” from the list and click Select
= Select “Group_43” from the list and click Select
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-

=

Groups

SetP45 -
SetP46
SetP47
SetP48
SetP49

4|

SetP94
SetPas e
Grou n 43

[ Sort Alphabetically
Group Name:

Group_43

} Create || Delete | Rename|

J,smect][ Add || Sub |

@or (JAnd () Xor
[] Auto Center

Done
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Workshop 1 (continued...)

-

Groups

SetP45 -
SetP46
SetP47
SetP48

SetP49

SetP94

SetP95

Group_43

[ Sort Alphabetically

Group Name:

SetP94

=

4|

| Create || Delete | Rename]

Select || Add || sub |

G

Save Load

@or (JAnd () Xor
[] Auto Center

Done
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Workshop 1 (continued...)

Modify part appearance...

Go to Model - Appearance

Select any one of the drawing modes Hide / Edge / View/ Wire
in the Appearance interface

Pick some parts in the model

Toggle Thick in the Appearance interface and pick the roof parts

Click the Zoom In render button (or hit Ctrl+Z) and zoom inon a
shell part to verify that thickness is displayed

-
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Appearance | &3 |
(@) Pick part
() Area @) In
) Polygon Out
© Off (") Feature
() Hide (") Edge
(") Shade ) Grid
) View (") Fringe

‘ 1 )G Wire () WireFring
[ | Mesh Thick @
I Shrn | NoFringe
[ |Isos || Sphere
| Leon || NoSection
| ShellThickne 1.0
@T/B (O Top ()Bot
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Create a view...

= Go to Model - Views

= Click Create (the current view will be saved as “View_01")

= Rotate the model and click Create again (saved as “View_02")
= Select “View_01" from the list and click Select

= Select “View_02” from the list and click Select

LS-PrePost Intro | 2016

@

Workshop 1 (continued...)

Views el
@) View MPP

View_01
View 02

View Name_number:
View_03

v | Color
| Appearance
v | Orientation 3

“KCreate H Select || Delete ‘

‘ Save H Load ‘

| Done |

©2016 Livermore Software Technology Corporation
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Identify nodes and elements...
= Turn on the mesh (using the Mesh render button) @

= Go to Element Tools = Identify

= Select Node in the Identify interface and pick some nodes in the

model to display their IDs

= Select Element in the Identify interface and pick some elements

= Toggle Elem Dir to display the N1 to N2 direction
= Click the Clear All button to clear all highlighted entities

LS-PrePost Intro | 2016
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Workshop 1 (continued...)

A~
Identify @ [&=]
1 @ Node () Element
(JPart () Particle
(C)CNRB  (C) Composite

Shel SPH Iner.
Solid Mass MNurbs
Beam Disc. Tshel

Seat. DiscSph. (@) AnyE

xyz coord

Show Results

Elem Dir [[INo ID

[ Mat Dir Fiber Dir
AirbagRG [] Show Popup

Echo ["] Part Name

intpt 1 -

intpt 2

intpt 3 N

Total identified nodes: 3
Total identified elems: 3
Total identified parts: 0
Total identified particles: 0
Total identified CNRBs: 0

l Clear Node ” Clear Part l

l Clear Elem ” Clear CNRB l

a Locate Elem
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Workshop 1 (continued...)

Find a node and element...

Go to Element Tools = Find and select Show Only
Enter 1439 in the text field and click Find
Click Neighbors several times

Click UnblankAll button

Select Node in the Find interface

Enter 5340 in the text field and click Find
Click Neighbors several times

Find 2%

(" MNode ©® Element
(" Part  CMRB

@ any ( Solid

1)s Show Only " _=Mighlight
Md/El/Part ID: ( i 51439

(" Beam
" Shell
(" ("

Unblankall | UnhlankPar‘t|

r Find @

2<

& Any
(" Beam
" Shell
-~

® Show Only
Nd/El/Part ID:

Unblankal |

(® Mode © Element
(— Part ( CMRB

" Solid
~
-~
~

{ __Highlight
5340

UnblankPart |

Find |Meighbors| Done

8 9
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Workshop 1 (continued...)

Blank some elements...

LS-PrePost Intro | 2016

Sel. Elem.(d)
Go to Element Tools - Blank
. . . i (- o Adjacent 2
Select Area in the General Selection interface and CL -Jabell® c ttach | S:E';T
d @ Add Clear
' ' (" ByGPart
draw a box to blank some elements o et CRM Tl bysubsys
. . . Load (— BySET
Click Reverse in the Blank interface | Telony -] oo ¢ o
. . . [ Label selection|  3DSurf Whole ™ ByPath
Click Unblank All in the Blank interface ¥ prool ™ adep anaf15 <] “vabie | €
Click the Assembly and Part (SelPart) render button @ m Roverss | 51001
y A \ y A
. . N
Select “88 PSHELL” from the list, click the Auto Center (AutCen) =
render button, and click Done in the Assembly and Part interface ——
. . . (" Mode (@ Element
Toggle Prop (propagate) in the General Selection interface, select C CNRB C Particle
Ang: 15, and pick an element on the front of the torso (" shell " sPH (" Iner.
(" Solid © Mass " Nurbs
(" Beam { Disc. (" Tshel
(" Seat. { DiscSph. (& AnyE
Apply
[ UnBlank Part
[v Auto-Apply
[v Auto-Update
L Blank All ‘ Update Surf‘
3 Unblankﬁll‘ Updedge ‘
Reverse ‘UnEIank Last‘
Done ‘
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Modify part color...

» C(Click the Activate All render button

Workshop 1 (continued...)

« Go to Model = PtColor

» Select Color

= Adjust color using the RGB sliders

= Select Set and pick some parts

= Select any color from color map

= Click Backg (only works when View > Background >

Plain is selected)

LS-PrePost Intro | 2016

@

Part Color &

ColorBy lPar‘tID vl

@ Color (") Transparency

| [

0
000 0.444 0.000 (=]
000 0.889 0.000
6

)-.5}.' Set () Show
{BackgH Text H skv }

| Hite || Outine | |Ground |

Done
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Modify part transparency...
= Select Transparency

=  Pick the roof of the structure and adjust the slider

= Select Pick Through and pick through the roof to make
some additional components transparent

= Click Visible and drag the slider to the far left
= Click Rstp button (reset all parts to opaque)

=  Click Amap button (reset parts color by color map)

LS-PrePost Intro | 2016
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Workshop 1 (continued...)

Part Color | x |

ColorB D -

() Color @) Transparency

HON S

[
I
T
C I ]
LI
]

Transparency factor
L 0.70

(@ Pick toggle
(*) Pick through

16
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Workshop 2

Mesh Generation

< Shape mesh
< N-line mesh
< Auto mesh
< Solid mesh

©2016 Livermore Software Technology Corporation
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Create a solid cylinder...

Workshop 2

Launch a new session of LS-PrePost
Go to Mesh - Shape Mesher
Select Entity: Cylinder_Solid

Enter Radius: 5, Length: 10,
Num Ele (Circumferential): 32, Num (Length): 20

Enter XYZ: 0,0,1 for position
Click dirz (set direction to 0,0,1)
Click Create and Accept C?:

Shape Mesher

Entity: |D,r||r1|:|er Solid l 1 )

Target Name

Start Element ID
Start Node ID

Create

e Done

li
Target Fart ID
li
li

Radius 3 1

Length | 10 | 1

numEle| | 32 1

Mum li 20 2 1
Position | Directinn‘

xliﬂ dirx lilil

) A((

[

LS-PrePost Intro | 2016 ©2016 Livermore Software Technology Corporation
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Workshop 2 (continued...)

Create a shell cylinder... rShape Mesher X
= Select Entity: Cylinder_Shell Entity: | Cylinder_Shell | Ll
» Enter Num Ele: 30 (leave other parameters unchanged) Radius | 5= 1 ]
=  Enter XYZ: 15,0,1 for position Length | w0 1
= Activate Top And Bottom (meshes ends of cylinder) 2 )tum Ele §
. Num 20 — 1
= Click Create and Accept N -
Position | DII’ECtIDrI|
= Turn on the mesh (using the Mesh render button) 3 5oanl o
= Rotate the model such that you can see the cross- Ty o an| o
section of both cylinders Zﬁgﬁ
(note the different cross-sectional mesh of the two v Top And Bottom
parts) @5
Target Name
Target Part ID 3
Start Element ID 6543
Start Node ID 7216
Create
Done
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Workshop 2 (continued...)

Create a mesh from 4 lines...

Launch a new session of LS-PrePost

File > Open > IGES File
(select /workshop2/test_4lmesh_curves.igs)

Click Open in the IGES Read Options popup
Go to Mesh - N-Line Mesher

Select Type: 4 Line Shell

Pick the longest curve

Pick the remaining curves in clockwise order
Enter N1: 24 and hit Enter
Enter N2: 12 and hit Enter
Enter N3: 20 and hit Enter
Enter N4: 10 and hit Enter
Click Mesh It and Accept

LS-PrePost Intro | 2016 ©2016 Livermore Software Technology Corporation

N-Line Mesher X
Type |4 Line shell - @
Mesh By:

(® Number of elements
(" Element size
(" Points of line

Mesh parameters

ni:| 24 1
Ratio:| 1.0 | Two End

n:f 12 1
g Ratio:| 1.0 | Two End

)N3:| 20+ 1
Ratio:| 1.0 | Two End

Na: | 1w - 1
Ratio:| 1.0 | Two End

Wire Sampling || MultiSelect
Fart ID: 1 J Mew PID

Mesh It

| ‘ Done |

©
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Workshop 2 (continued...)

Sweep one line along another...

Launch a new session of LS-PrePost

File > Open > IGES File
(select /workshop2/sweep _lines.igs)

Click Open in the IGES Read Options popup
Go to Curve - Circle

Select Method: Parameters

Click the “.” button next to Origin Point X

Select Geometry in the Create Position
interface

Pick the endpoint of the remaining curve
Click Done in the Create Position interface
Enter Direction XY Z:100

Enter Radius: 50 and click Apply

Create Circle m 2%

Origin Point

Y m:”ﬁb
z| -250 < 1.0

Direction

x[ 1

Y 0.0

z[ o

Radius SD@

| Sketch on Flane

Method WA
o] )

Create Position 2%
(s ("
(" Position ( Mode

(— C_Element 1 C_Edge
(" Avg_Cen ( 3PtCircle

( C_Cur/Surf (& Geometry
X:|D

v:[164.6

z:|-250

| Done Cancel

MID| 1 ( 5 )Create

Apply | | Close |

10,

©2016 Livermore Software Technology Corporation
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Workshop 2 (continued...)

Sweep one line along another... N-Line Mesher

» Go to Mesh - N-Line Mesher Type [Line sweep v | @
= Select Type: Line sweep Mesh By:
= Select Mesh By: Number of elements ? Number Dfelements@
Element size

= Pick the circle as L1 " Points of line
» Pick the red line as L2 Mesh parameters
= Click the up arrow near L1 several times to increase N1 to 15 N1 | 154 1
=  Click the up arrow near L2 several times to increase N2 to 20 s o ak
= Enter Part ID: 2 N2l 20 1

i io:| 1.0 d
= Click Mesh It and Accept e | TwoEn

|+ Native Path Tangent

[ Center Align{move)

[ Align Closed Fath
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Workshop 2 (continued...)

Auto mesh an STEP file using Auto mesh...

Launch a new session of LS-PrePost

File > Open > STEP File D P PAAH

Middle Surface |

(select /workshop2/bottle.stp)
Click Open in the Open File Options popup
Click the IsoMetric render button
Go to Surf - MidSurf

Select Method By Solid

Pick Solid 1

Activate Stitch Mid-Surfs

Click Apply

Click Close

od

&
&

Solid

Mid Surfaces Pair:

MO <12, 1> -
M1 <64, 41>

M2 <19, 8> -
Max Gap 0.0

Sort@ No () By gap
Location(%): 50.0 =
Search Pairs Strictly

Stitch Mid-Surfs

Post Actinn

LS-PrePost Intro | 2016 ©2016 Livermore Software Technology Corporation
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Workshop 2 (continued...)

Auto mesh an STEP file using Auto mesh...

Inactivate Soild 1 in feature tree

LS-PrePost Intro | 2016

ki LS-PrePost(R) V4.2 -

File Misc. View Gec

|
71 Assembly 1
A Shap oup

77 Shell 2
7 Geom Parts
7 Part 1

©2016 Livermore Software Technology Corporation
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Workshop 2 (continued...)

Purpose : Auto mesh an STEP file using Auto mesh...

= Go to Mesh - AutoM

= Select mesh mode by Size

=  Enter Elem Size : 1.0

= Click Visible on Sel. geom interface

= Click Mesh

= Click Accept

= Click Done

= Click EdgGeo render buttons turn geometry off

LS-PrePost Intro | 2016

@

Sel. geom(0)
@ Pick @ In Clear W W
" Area § Out Save
@ Add __Load
¢~ mm  Deselect
Whaole
D
Visile &
Reverse @
B w &

EdgGeo ShaGeo WirGeo

©2016 Livermore Software Technology Corporation

Auto Mesher
Mesh Mode

> Q) Size
Deviation

Remesh

Variable Size Mesh

Mesh Type Mlxed ( )

Elem Size

‘Compute” Reset |

Connect Boundary Nodes

Mesh Across Suppressed Edges

Show Meshed Boundaries

Auto Remesh Boundary

Manual Remesh Boundary
¥| Mesh by GPart

Ignored Hole Size

Merge Tolerance

Part ID

1

0
0.0001
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Workshop 3
Model Editing

<+ Model free edge

< Duplicate nodes merge

<+ Node and element Editing
< Fill holes

<+ Element normal align

< Save a keyword file

©2016 Livermore Software Technology Corporation
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Merge duplicate nodes...

Workshop 3

= Launch a new session of LS-PrePost
= File > Open > LS-DYNA Keyword File (select

/workshop3/badmesh.k)

= Go to Element Tools - Duplicate Nodes and turn on the mesh
(using the Mesh render button)

= Activate Show Free Edges
» Enter Tolerance: 1.0

= Click Show Dup Nodes (see figure)

= Click Merge Dup Nodes
= Click Accept
= Click Done

LS-PrePost Intro | 2016
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Duplicate Nodes 4

Tolerance:

Q@ Keep Smaller NID
Keep Larger NID

Centroid XY Z
3
| Show Dup MNodes
Select Nodes
Merge Dup "'-.-ZIC|-E'S@

Clear

)»f Show Free Edges
Adaptive Edges

V| Delete Merged Nodes

v| Delete Degenerated Elem

| Clean Model

Line Width |3 -
Line Color |White -

10
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Workshop 3 (continued...)

Replace nodes...

Go to Element Tool - Node Editing
Select Replace
Select Area and MidPoint

Zoom in the internal free edges area, select two nodes at a time for
merging (by drawing a window)
Click Accept

Repeat @ and @ until all internal free edges have been
eliminated

LS-PrePost Intro | 2016 ©2016 Livermore Software Technology Corporation

Node Editing | |
() Create (@ Replace
() Delete () Align
) Modify

Show Free Edges

@ Two () Many
() Pick Node @ ﬂrea@
Nodel
[ Node2

(") At Nodel

() At Node?
)c MidPoint @

Reject || Accept

28



Create a tria element...

LS-PrePost Intro | 2016

Workshop 3 (continued...)

Go to Element Tool - Element Editing Cl:
Select Create

Select Elem Type: Shell
Activate PID and pick the part
Activate Tria Only

Pick the 3 nodes to fill the final gap in the part o @:
Click Accept

Reject

©2016 Livermore Software Technology Corporation

Element Editing 2]

() Check () Split/Merge

@) Create () Modify

() Delete (") Direction

() Composite (") Align

Show Free Edges

Elem Type: ’Shell v(

Elem ID: 2998 \New EID
)rieo: 1 [Jewin

Nodel

[ Node2

[ Node3

MNode4
W] Tria Onfy@
[ Replace

Redefine

29
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Workshop 3 (continued...)

Align nodes along a line...

Go to Element Tool - Node Editing
Select Align
Click the Right render button

Click the Zoom In render button and zoom in as
shown

Pick 2 nodes to form a line
Pick the nodes in between
Click Align

Click Accept

Node Editing [

(") Create () Replace
() Delete @) Alig

() Modify

Show Free Edges

@ Node () PtOnElem
[ | Point1 [ | Point2
X 2008.095703 1933.057007
Y 668.602783 669.688171
Z 808.809814 794.979248
Nd 3452 3459

DSdeE‘ Clear H.‘}huwﬂd‘

Reject || Accept

) [ome] (&)

©2016 Livermore Software Technology Corporation
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Workshop 3 (continued...)

Split elements...

= Go to Element Tool - Element Editing

= Select Split/Merge

= Activate Constrain Adaptive

= Pick the elements around the hole as shown
= Click Apply

= Click Accept

g
K " o) l.’
DO

ST S

e

P

ErementEditingQ_) =3
Check @) Splt/Merge

Create Modify
Delete Direction
Composite Align

¥ | Show Free Edges

Split Operation:|Shell -

@)« @ E Retain Bdy

b A

N A
] [Y]
NJEN

| Constrain Adaptive

Merge Operation:

LS-PrePost Intro | 2016 ©2016 Livermore Software Technology Corporation
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Workshop 3 (continued...)

Fill a hole...
= Go to Mesh - Element Generation

= Select Shell

= Select Shell By: Fill_Holes

= TypelinPartID

= Pick any node on the perimeter of the hole
= Click Create
= Click Accept

Element Gene@ &l

\

AR AL T

@

T

Beam (@) Shel Solid
Element ID:
3576 @/
Part ID: Pick PID
New node:
5658 New NID
77 N\
Shel By:(FilHoes (2 ) ]

NS

Keep smooth
| Connect boundary node
Q) Closed Hole

Open Hole

Polygon

Auto Fil

eate || Reject || Accept

() Lome]

LS-PrePost Intro | 2016 ©2016 Livermore Software Technology Corporation
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Align shell normals...

» Go to Element Tools & Normals

= Select Show Normals (should be already selected)

» Click Visible in the General Selection interface

= Select Align

= Click Pick seed element
= Pick any element that is |

= Click AutoRev
= Click Done

Workshop 3 (continued...)

Deselect

Jhole

| Cvebis

Reverse

LS-PrePost Intro | 2016

Normals &3 Normals &3
Entity Type: |She||5/\ - Entity Type: |Shels v|
@) Show Normal w Show Normal
Reverse Normal Rever, al 5
Align Q) Align
V-5ize 20 =1 V-5ize =1
Q) Compliment Dimmed @ Seed ele. 505
Airbag Shel RG Airbag Node RG
Towards .
Airbag Shel RG Airbag Node RG
AutoRe Clear ||Reverse||AutoRev
A Done

©2016 Livermore Software Technology Corporation



Workshop 3 (continued...)

Save the modified input file...

File > Save As > Save Keyword As...

Click Browse

Enter a file name (save as /workshop3/goodmesh.k)
Click Save

Save Keyword
Save Keyword File

File Name:

wnloads\WORKSHOPS\workshop3\goodmesh.k ‘ Browse

Output Version: |V971_R8 ~ Long Format ‘ Advanced ...

Save ‘ Renumber ‘ ‘ Offset ‘ ‘ Cancel
2

—/

LS-PrePost Intro | 2016 ©2016 Livermore Software Technology Corporation
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Workshop 4

Build a fan model

< Create a surface

< Surface mesh

< 2Line mesh

< Part trim

< Model transform (rotate)
< Save a keyword file

©2016 Livermore Software Technology Corporation
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Workshop 4

Create a surface...
= Launch a new session of LS-PrePost

= File > Open > IGES File
(select /workshop4/hub.igs)

= Rotate model as shown in figure
=  Go to Surf - N-Side
= Pick edge 8,5,6,7 then click Apply

Surface mesh...

= Go to Mesh - AutoM

= Select mesh mode by Size
=  Enter Elem Size : 3.0

= Pick Face 1 then click Mesh
= Click Accept

= Click Done

LS-PrePost Intro | 2016

(2o ] v

-

4{Cur)

©2016 Livermore Software Technology Corporation

.

Create N Side Surfa...| £3 |

Edge List

8 (Edge)
5 (Edge)

6 (Edge)
=

["]Auto Close
["] Smooth Curve
[] Try to Stitch

L2

Auto Mesher
Mesh Mode
@) Size
() Deviation
() Remesh
() Variable Size Mesh

Mesh Type
Elem Size 3

[] Connect Boundary Nodes
["IMesh Across Suppressed Edges
Show Meshed Boundaries
(@) Auto Remesh Boundary
Manual Remesh Boundary
Mesh by GPart
Ignored Hole Size 0

Merge Tolerance 0.0001

Part ID 1.

4 Reject || Accept
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Workshop 4 (continued...)

Hub mesh(sweep)...
= Goto Mesh - NlineM

= Select mesh type by Line Sweep
=  Enter N1: 11 hit Enter and N2: 12 hit Enter

= Activate Multi_Select

= Pickcurvell 1andLl1l_2
= Inactivate Multi_Select

= Pick curve L2

= then click Mesh

= Click Accept

= Click Done

LS-PrePost Intro | 2016

v | Multi-Select

Multi-Select

)

s
L |
:‘l
<&

el 1108 L3

=<

L L o e
s
—
3]

\

\

“»

N-Line Mesher P
Type|Line Sweep

Mesh By:

@ Number of Elements
Element Size
Points of Line

Mesh Parameters

M1 11 = 1
Ratio: 1.0 | | Two End

N2 12 = 1

Ratio: 1.0 | | Two End

| Native Path Tangent
Center Align{mave)

Align Closed Path

Wire Sampling Mufti-SeIect(
Part ID: 2 H New PID
Mesh It

Done

Accept || Reject

©2016 Livermore Software Technology Corporation
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Workshop 4 (continued...)

Blade mesh...

=  File > Import> IGES File
(select /workshop4/blade.igs)

= Go to Mesh - NlineM

= Select mesh type by 2 Lines Shell

= Enter N1: 20 hit Enter and N2: 20 hit Enter
= Enter N3: 12 hit Enter and N4: 12 hit Enter
= Pickcurve Ll and L2

= then click Mesh

= Click Accept

= Click Done

N-Line Mesher | 53
Type|2 Lines Shel @

Mesh By:

(@ Number of Elements
Element Size
Points of Line

Mesh Parameters

M1 20 = 1

) Ratio: 1.0 | | Two End
N2 20

z 1
Ratio: 1.0 [ | Two End

N3 12 = 1
Ratio: 1.0 [ | Two End

N4 12 = 1

Ratio: 1.0 | | Two End
Stitch Method

Wire Sampling|| | Multi-Select

Part ID: 3 H New PID
‘ : EMesh It

Accept || Reject || Done

LS-PrePost Intro | 2016 ©2016 Livermore Software Technology Corporation
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Trim curve create...

= Go to Curve - Spline
= Inactivate Piecewise
» Picknodes1,2,3,4,5and 6

= Click Apply
» C(Click Close

LS-PrePost Intro | 2016

Workshop 4 (continued...)

Create BSpline Cur... @

Method[lnterpolate Pnts V]

Selection List

[ Piecewise Q)
[ | Closed

[] sort Points

[ Sketch on Plane

O

©2016 Livermore Software Technology Corporation
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Workshop 4 (continued...)

Trim blade...

Save a project file...

LS-PrePost Intro | 2016

Go to EleTol - PtTrim

Click Closest 3D proj dir.

Select Parts, pick part 3 (blade)
Select Curves, pick trim curve

Select Keep, pick a seed element need to keep
Click Trim

Click Accept
Click Done

Go to File > Save > Save Project

Enter a file name (save as
/workshop4/fan.proj)

Click Save

Part Trim @

Trim Entities

@) Parts

Trim Tool

(") Curves (") RefPlane
Operation

()Keep () Delete () Move
Parameters

Limit: 10.000000

Tolerance: 0.4
Trim method
(@ Closest 3D proj dir.
() Vector projection
Vector
Y 7

0. 0. 1.

Trim || Reject || Accept
Done

©2016 Livermore Software Technology Corporation
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Workshop 4 (continued...)

Model rotate...

Click EdgGeo render buttons turn

geometry off

Go to EleTol - Transf
Select Rotate

Select Rot.Axis: Z

Enter 120 at Rot. Angle
Activate Copy Elem
Activate Transfer

Click Visible in the General
Selection interface

Click Rotate+

Click Accept

Click Rotate+ again
Click Accept

Click Done

LS-PrePost Intro | 2016

¥ w &

EdgGeo ShaGeo WirGeo

Transform
(") Transform
() Translate

@)

@) Rotate

Airbag Shell RefGM
Airbag Node RefGM

(O Reflect
() Project

() Scale

)

Rotate Model
"] Free Edit

Rot. Axis:[Z

NodelD:
XYZ:
Rot. Angle:

@) Global

[ Pick origin

©) Local

Coord Sys

l Rotate- ” Rotate+

@

Options
Copy Elem
[] Copy Entity

No. of copies:
[ Pick Part

Starting EID:
Starting NID:
6 [¥] Transfer

Copy Node

1947
2236

Reject || Accept

(@

©2016 Livermore Software Technology Corporation
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Workshop 4 (continued...)

Duplicate nodes merge...

Go to Ele Tol - DupNod
Enter Tolerance: 0.1
Activate Show Free Edges
Click Show Dup Nodes
Click Merge Dup Nodes
Click Accept

Click Done

Save a keyword file...

LS-PrePost Intro | 2016

Go to File > Save > Save Keyword

Enter a file name (save as
/workshop4/fan.k)

Click Save

Duplicate Nodes 2

Tolerance: 0.1 1

Q@ Keep Smaller NID
Keep Larger NID
Centroid XYZ

| Show Dup Nodes

Select Nodes

Merge Dup Nodes

Clear

) | Show Free Edges
Adaptive Edges
| Delete Merged Nodes
V| Delete Degenerated Elem
V| Clean Model

Line Width |3 -
Line Color |White -

OXO,

Reject || Accept || Done

©2016 Livermore Software Technology Corporation
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LS-PrePost Intro | 2016

Workshop 5

Create a Keyword File
(S-Rail to Rigidwall Impact)

<+ Mesh model

< Assign material and property

< Apply mass, constraint and velocity
< Rigid wall creation

< Define spot welding

< Save a keyword file

<+ Model comparison

©2016 Livermore Software Technology Corporation
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Workshop S (continued...)

Import and mesh IGES surfaces...

= Launch a new session of LS-PrePost

= File > Open > IGES File (select
/workshop5/channel.igs and flat.igs both)

= Click Open in the IGES Read Options popup

= Go to Mesh - Auto Mesher

=  Enter Elem Size: 6

= Click Visible in the General Selection interface

» Click Mesh  |openrie X
. ()=l « 2014 » WORKSHOPS * warkshopb v| 3 || Search workshops )
«  Click Accept |
Organize ~ New folder SN i e
" CI ICk Done Favorites in Name : Date modified Ty
B Desktop channel igs 6/3/2008 1118 AM  IG

¢+ Downloads flatigs 6/3/2008 1118 AM  IG

m

« Dropbox

«» Recent Places
% iCloud Photos

- Libraries
“. Documents
4. Music
~. Pictures
: - 4 11 3
Cuibararcian
v [16ES Filefigrs) ~|
‘ Open |VH Cancel ‘

LS-PrePost Intro | 2016 ©2016 Livermore Software Technology Corporation 44



Workshop S (continued...)

Define section property...
= Click EdgGeo render buttons turn geometry off @ w &

EdgGeo ShaGeo WirGeo

= Go to Model - Keyword Manager

= Select All

=  Expand SECTION

= Double-click “SHELL”

= Click NewlD in the Keyword Input Form

= Enter TITLE: 1.0mm

= Enter ELFORM: 16, T1: 1.0 (and hit the Enter key)
= Click Accept and Done

7\
Keyword Input Form @ 6

1 NewlID | Draw | RefBy ‘ Sort,-’Tl‘ Add ‘ Accept‘ Delete ‘ Default‘ Done ‘

| Use *Parameter (Subsys: 1) Setting

*SECTION_SHELL (TITLE) (0)

IITLE i
2 |1.I2Imm g
1 SECID ELFDRM@& NIP PROPT QR/IRID ICOMP SETYP S
[ 1 ~1[10 [2 1 ~][o [0 =t >
211 =y 12 13 I4 NLOC MAREA IDOF EDGSET
10 o |1.0 1.0 |1.0 10.0 10.0 10.0 0

LS-PrePost Intro | 2016 ©2016 Livermore Software Technology Corporation



Workshop S (continued...)

Define material property...

=  Expand MAT in Keyword Manager

= Double-click “024-PIECEWISE_LINEAR_PLASTICITY”

= Click NewlD in the Keyword Input Form

= Enter TITLE: Mild Steel

= Enter RO=7.83e-6, E= 207.0, PR= 0.3, SIGY= 0.2, ETAN= 2.0
= Click Accept

= Click Done
7\
Keyword Input Form w 5
1 / MatDB | RefBy | Pick | Add | Accept| Delete | Default| Done ‘

[ Use *Parameter (Subsys: 1) Setting

*MAT_PIECEWISE_LINEAR_PLASTICITY_(TITLE) (024) (0)

me (7)) :

| Mild Steel “r!!
1 MID RO E PR SIGY ETAN EAIL TDEL =
|1 |7.83e-6 |207.0 10.3 0.2 2.0 | 10.E+20 10.0

©

LS-PrePost Intro | 2016 ©2016 Livermore Software Technology Corporation



Assign section and material...

LS-PrePost Intro | 2016

Workshop S (continued...)

Go to Model - Part Data
Select Assign

Click All @
Click SECID

Select “1.0mm” in the Link SECTION interface
Click Done in Link SECTION interface

Click MID

Select “Mild Steel” in the Link MAT interface
Click Done in Link MAT interface

Click Apply

Click Done

Part Data | 2%
(" Show  Cre { Mod (" Sear
(@ Assign  Prop { Replace

ParTType|SheII J

(8 *PART Parameter ( *SECTION Formulation
\mgr Prop

SECID MID EOSID
E E | |
TMID GRAV ADPOPT

| A x| [na =]

HGID

Assign Part | Apply

Part List:

5 1 LSHELL1
5 2 LSHELL2

©,

All ‘ None Rev ‘

Done ‘

©2016 Livermore Software Technology Corporation
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Workshop S (continued...)

Add mass to end of rail...

LS-PrePost Intro | 2016

Click the Top render button

Click the Zoom In render button and zoom in on the
right end of the rail

Go to Model - Create Entity

Expand Element

Select Mass

Select Cre

Enter Mass: 2.0

Select Area in the General Selection interface

Click and drag to select 1 row of nodes along the end of
the rail (see 3)

Click Save - To Buffer - Bufferl in the General
Selection interface

Click Apply

Select Show

Select Label: MassValue

Click Visible in the General Selection interface

Entity Creation

—-Airbag

. ShelRefGM
+- Application
+-Boundary
+-Constrained
+-Contact
+-Damping
+-Database
+-Define
—I-Element

. ~Beam-End Release
-~ Mass
/ - Seatbelt Accelerome

PG
@) Show Cre Mod Del
Label:| MassValue v|
Mass 2.0 2
PID e

a
-h
"
-
»
=
"
-
o
-
n
-
a
-l
a
-
a
o
o
-
L
-
-
~
L
-
a
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Workshop S (continued...)

Create constraints at end of rail...

= Expand Boundary in entity creation

= Select Spc

= Select Cre

= Activate Y, Z, RX, RY, and RZ (everything except X)

» Click Load = From Buffer = Bufferl in the General
Selection interface

. N
= Click Appl ) _
PPly Entity Creation 2 28
e
[+)- Airbag (" Show @ Cre ¢ Mod (" Del
(- Application -
E--Bpundary |b'_-"|'|‘|bD| J
L Spe (® Set " Node
[#- Constrained o
" Contact ‘ | @) ByNode
[+- Damping : s
--Database Symmetry pIane|AII Fix[111111] ﬂ Adjacent yElemn
B Define X Y Z RX RY RZ Attach ByPart
BH- Element W W M v ¥ Clear ByGPart
& Initial — Birth | i BySubsys
i- Load W load | (7)BySet/Grp
" Rigidwiall Death| 1.0E+20 Deselect ByEdge
[+ Set Data co| Whole ByPath
Visible B
ySeqgm
NSID 2 Newld
Reverse ByCurve
| ‘ | BySurf
< Apply ‘ | Write |
NSet 1 (011111) (sub:1

LS-PrePost Intro | 2016 ©2016 Livermore Software Technology Corporation



LS-PrePost Intro | 2016

Workshop S (continued...)

Create initial velocities at end of rail...

Expand Initial in entity creation
Select Velocity

Select Cre

Enter Vx: -10.0

Click Load = From Buffer - Bufferl in the General

Selection interface
Click Apply

i

Entity Creation

() =

[#- Airbag
--Application
[H- Boundary
[H- Constrained
[+- Contact

(- Damping
[ Database
(- Define

[H- Element
= Initial

-- Load
[ Rigidwall
[#- Set Data

(" Show ® Cre © Mod ( Del
|rlcne J

CreateT}rpe|GInhaI

li@li

(

Apply

|5409 (sub:1) -

©2016 Livermore Software Technology Corporation
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Workshop S (continued...)

Create a rigid wall...

= Click the Auto Center (AutCen) render button
» C(Click the Zoom In render button and zoom in on the

left end of the rail
=  Expand Rigidwall in entity creation
= Select Rigidwall
= Select Cre
= Select Planar
= Select NX (you may have to scroll down)
= Pick any node at the left end of the rail

» Select Tran

enter Distance: 10 0 5 0 0 2

= Click Tran -

- Click Apply (IERENE S UIA AR R

= Click Done

or i

NN
Entity Creation ( 2 ) X
N”
[H- Airbag (" Show @ Cre ( Mod ¢ Del
(- Application i
) Boundary | Display Node Set
[ Constrained |S*,-'mh0| J
[- Contact
[- Damping " Geom || Finite| Force &
[ Database ® Planar [ Mov [ Ortho
[ Define
[ Element (® GeoVector
[ Initial " Title
[ Load (" SlaveMode
= Rigidwall | 4
. --Rigidwall
B Set Data @ 1n+NL ¢ NI-NZ O 3Nds
O (" Tran ¢ Rota
Refl
7 X Y i
j‘ 0 | 255.133 ‘ 0
<
ﬂ‘ 12?.56?| 255.133‘ 0
v Node | 4675
. X NY (" NZ
Clear
Apply ‘
Translate @ Global Local

Distance

(8)oxt Cvm Oz

4 Tran- 2 Tran+

LS-PrePost Intro | 2016 ©2016 Livermore Software Technology Corporation
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Workshop S (continued...)

Create welds using a master weld file...

=  Go to Mesh - Spot Welding

= Select Format: Primer (from the drop-down menu)
= Click Open (select /workshop5/welds.spot)

= Click Open in the Read Options popup

= Click the Wire render button to see weld locations
= Select Properties: File

= Click Browse (select /workshop5/spot.conf)

= Click Open in the Read Options popup

= Click Create

= Click Accept
= Click Done

Spot Welding PG

@ Swgen Swereate

€>| Open HPrimer -

Unload WF

Properties
GUI (@ Fie

Search radius: 7.0
Min Length: 0.5
[ [u [u [u
Weld type
Q@) Beam One Elem
Solid Four Elems

N
C3) Browse ” View
-

KSHOPS\workshop5\spot.conf"

Create || Reject || Accept

Done

LS-PrePost Intro | 2016 ©2016 Livermore Software Technology Corporation
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Define contact...

Workshop S (continued...)

Go to Model - Keyword Manager

Select All then expand CONTACT
Double-click “AUTOMATIC_SINGLE_SURFACE”
Click NewlID in the Keyword Input Form

Set SSTYP: 2

Click the Link Button next to the SSID field

Select “1 spotweld part set” in the Link SET

interface

Click Done in the Link SET interface

Click Accept
Click Done

®-

LS-PrePost Intro | 2016

Keyword Input Form

NewlID || Draw
Use *Parameter

1 CID TITLE
2

2

3

4 SSID MSID

@

O,

| Pick H Add HAccept”Delete||Default|

~
—~
~

Done ‘

(Subsys: 1 New_Subsystem_1) Setting

*CONTACT_AUTOMATIC_SINGLE_SURFACE_(ID/TITLE/MPP) (1)

3

MPP1

gE

~Jo

-

0

MPP2

1.0005

2
5 @
SSTYP STYP SBOXID MBOXID SPR

BIE

MPR

-

[

~Jo

©2016 Livermore Software Technology Corporation
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Workshop S (continued...)

Set termination time...

= Go to Model - Keyword Manager

= Select All

=  Expand CONTROL

= Double-click “TERMINATION”

=  Enter ENDTIM: 10 in Keyword Input Form
= Click Accept

= Click Done

Set d3plot frequency...

=  Expand DATABASE in Keyword Manager
= Double-click “BINARY_D3PLOT”

=  Enter DT: 1 in Keyword Input Form

= Click Accept and Done

LS-PrePost Intro | 2016

Keyword Input Form

[ Use *Parameter

DTMIN

*CONTROL_TERMINATION (0

ENDENG ENDMAS

1 ENDCYC
C [0 D0

|00

|00 |00

Keyword Input Form

[ use *Parameter

*DATABASE_BINARY_D3PLOT (0)

NPLTC PSETID

2 IOOPT

O

| |
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Expand DATABASE in Keyword Manager
Double-click “ ASCII_option”
Enter Default DT: 0.1 (and hit the Enter key)

Activate GLSTAT

Activate MATSUM
Activate SWFORC (spotweld forces)
Click Accept and Done

LS-PrePost Intro | 2016

Workshop S (continued...)

Set ASCII output frequency...

Keyword Input Form %
Accept ‘ Dane ‘
[ Use *Parameter
@ *DATABASE_OPTION (0)
Default DT |0.1 ; Default BINARY |0 -
Default LCUR Default IDOPT |1 v
[~ ABSTAT DT BINARY LCUR I00PT
K OO | R T—
| GLSTAT DT BINARY LCU I00OPT
0.1 0 |0 (] -
v MATSUM DT BINARY LCU I00OPT
0.1 0 |0 (] -
| RWFORC DT BINARY LCU I00OPT
0.1 0 | 0 1 -

©2016 Livermore Software Technology Corporation
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Workshop S (continued...)

Save keyword file...

= File > Save As > Save Keyword As...

= Click Browse (save as /workshop5/srail.k) then Save
= Click Advanced...

= Click customize order: Expert

= Click Ok in the Advanced Setting interface

= Click Save in the Save Keyword interface

LS-PrePost Intro | 2016 ©2016 Livermore Software Technology Corporation



Workshop 5 (continued...)

Compare a set of LS-DYNA Keyword files...

LS-PrePost Intro | 2016

Launch a new session of LS-PrePost

File > Open > LS-DYNA Keyword File
(select /workshop5/compare/beltedl.k)

File > Open > LS-DYNA Keyword File
(select /workshop5/compare/belted2.k)

Go to Model - MSelect

Select Compare

Click in the 1st Model field and select model 1
Click in the 2nd Model field and select model 2
Click Compare

P

A

Model Selection X

1-HYBRID III RIGID Dumrr
2-LS-DYNA keyword deck b

@ Keyword
D3PLOT
1st M 2nd Model

Compar
=0

Type:|Stress -

v |

Componets Name:
L

State: - |

Fringe Diff |

Done |

) Select @ Compare (D

1 2 @)

©2016 Livermore Software Technology Corporation
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Workshop 5 (continued...)

Compare a set of LS-DYNA Keyword files...

= Select the Common Keywords tab

= Examine the RED items to identify differences

Model Compare/—\

Summary Info

B AIRBAG
H- BOUNDARY

f CONSTRAINED
- CONTACT

Commaon Keywords

odell only | Model2 only

Keyword count :

CONTROL_OUTPUT(Y, 1)
1

Keyword ID range: 116 To 116

E"C?;‘JE{E ;IS o Field #1 | Field #2 Field #3 Field #4 Field #5 Field #6 Field #7 Field #8  Field #9 Field #10 =
 CONTACT(L = Card #0 NPOPT 'NEECHO NREFUP IACCOP OPIFS  IPNINT IKEDIT IFLUSH
- COUPLING(1 Value 1 0 0 0 0 0 0 B 5000
LCPUL D) Value 2 0 0 0 0 0 0 HOE 5000
- DAMPING(1,
~ENERGY(L, 1 Card #1 IPRTF [ERODE TET10 MSGMAXIPCURY GMDT IP1DBLT EOCS :
- HOURGLASSCR Valuel 0 0 2 50 0 0 0 0
?ﬁgf&;‘i')l Value 2 0 0 2 50 0 0 0 0
- STRUCTUREI
- TERMINATIC Card #2 TOLEV  NEWLEG FRFREQ MINFO SOLSIG MSGFLG CDETOL
-~ TIMESTER(L, Value 1 2 0 1 0 0 0 10 N
G- DAMPING Value 2 2 0 1 0 0 0 10 il
#-DATABASE =
] N [C] ViewAll Dral.ﬂ.-‘[ Keyword 1 “ Keyword 2 ]
WriteSummary H WriteDetail “ Done l

LS-PrePost Intro | 2016
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LS-PrePost Intro | 2016

Workshop 6

Post-Processing

< Animation interface

< Fringe (contour) plotting

< Time history/ASCI| data plotting
< Section cut

< Cross plotting

< Vector draw

©2016 Livermore Software Technology Corporation
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Workshop 6

Load results d3plot file...

Launch a new session of LS-PrePost

File > Open > LS-DYNA Binary Plot
(select /workshop6/d3plot), click Open

Click the Top render button

Click Animate Forward
(click the Anim render button first if necessary)

Decrease the animation speed using the slider

Generate a movie...

LS-PrePost Intro | 2016

File > Movie...

Select Format : JPEG

Enter File Name: animationl
Click Start

Jo

P4

Animate

Eigen First:

Animate

125 — 1

28
1 Last: 12 Incc 1 Time; 10.0002|State: 12

®

®

©2016 Livermore Software Technology Corporation
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Workshop 6 (continued...)

Create a fringe contour plots... Fringe Levels

= Go to Post - Fringe Component 5.184e-01
= Click Ndv 4.666€-01 ]
4.147e-01 _
= Select “result displacement” from the list 3.629e-01 _
= Click Animate Forward 3.111e-01 _
(if the animation is not already playing) 2.592e-01 _
2.074e-01 _
»  Click Stress 1.555¢-01 _

1.037e-01

5.184e-02 :I
0.000e+00

» Select “von mises stress” from the list

= Click Stop Animation

LS-PrePost Intro | 2016 ©2016 Livermore Software Technology Corporation



Workshop 6 (continued...)

Modify range settings...

= Drag the slider to the last frame

= Go to Post - Fringe Range (FriRang)

= Select Avg: None

= Activate Reverse Colors

= Activate Ident Min and Max

=  Enter No. Min/Max Entities: 1 (and hit Enter)
= Select Level: 20

= Click Animate Forward
(if the animation is not already playing)

= Click Stop Animation

= Click the Shade Element (ShaEle) render button

LS-PrePost Intro | 2016 ©2016 Livermore Software Technology Corporation



Workshop 6 (continued...)

Identify nodes and elements by ID...

= Drag the slider to the last frame

= Go to Post - Fringe Range (FriRang)
= Click Stress

= Select “von mises stress” from the list
= Go to Element Tools - Ident

= Select Node

= Activate Show Results in Identify

= Go to View (drop down menu)

= Activate Results On Screen in view
=  Pick some nodes in the model

= Select Element

=  Pick some elements by clicking

= Click Clear Node

= Click Clear Elem

= Click Done in Identify

LS-PrePost Intro | 2016

®

Identify &3
@) Node

Part Particle

CNRB

Element

Composite
Shell SPH Iner.
Solid Mass Nurbs
Beam Disc. Tshel
Seat. DiscSph. AnyE

XyZ coord Node

V| Show Results

Elem Dir No ID

Mat Dir Fiber Dir

AirbagRG Show Popup
V| Echo Part Name
intpt 1 -
intpt 2
intpt 3 v

Total identified nodes: 0
Total identified elems: 0
Total identified parts: 0
Total identified particles: 0
Total identified CNRBs: 0

‘ Clear Node H Clear Part ‘

‘ Clear Elem H Clear CNRB ‘

‘ Clear All HLocate Elem‘

Done

s

©2016 Livermore Software Technology Corporation

Full Screen (Esc to Exit)

Background
Geometry Shade
Element Shade

All Elements
All Geometry
Ref Geometry
Paints

Curves
Surfaces

Grid

Toolbar

Local Axes

Beam Prism

Beam Prism Fast
Smooth Fringe Color
Keep Zout Orientation
Show Deleted Nodes
Show Deleted Elements
Results On Screen
Smooth Shade

Record Message
Show Mid-Side Nodes
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Workshop 6 (continued...)

Plot time history data...

= Go to Post = History

= Select Nodal

= Select “Z-displacement” from the list
= Pick 2 nodes on the Model

= Click Plot

= Click Quit in the Plot Window

= Select Element

=  Select “Effective Stress (v-m)” from the list
= Pick an element on the plate

= Click Plot

= Click Quit in the Plot Window

= Click the Clear render button

& PlotWindow-1 o || B ER

Node no.

(-2
(=]
‘m

A 1694
B 1874

(4]
(-]

[4)]
(-]

(4]
B

(3]
N

Z-coordinate
w

[4)]
o
>

‘-\L A A

IS
[+-]

B
(-]

2 4 6 8 10

o

Time

SRS | Title ‘ Scale | Attr ‘ Filter ‘ Print | Save ‘ Load | Oper ‘ Hide | Close ‘ Quit

e

LS-PrePost Intro | 2016

& PlotWindow-1 o || B R

0.2

Element no.

/Q/\A\

A 814

RN

g m), ip#gax
S o
‘\‘\-_

Effectige Stress
o
o
\\*\

0 2 4 6 8 10
Time

SRS | Title ‘ Scale ‘ Attr | Filter ‘ Print | Save ‘ Load ‘ Oper | Hide ‘ Clusz| Quit
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Plot ASCII data...

LS-PrePost Intro | 2016

Workshop 6 (continued...)

Go to Post - ASCII
Select “rwforc *” from the top list
Click Load

Select the “Wall1” and “4-Normal Force”
in the bottom list

Activate Main in ASCII dialog

Click Plot in ASCII dialog

Select Show Port at XY-Plot Page Manager
Right click “Port1:*” then select Control
Activate Timeline in XY-Plot Port Control
Click Animate Forward

Click Hide at XY-Plot Page Manager

Click Stop Animation

@

ASCI

g

File
Load

Unload

Clear

Info

glstat *
matsum *
abstat
rcforc
ncforc
nodout
elout
cacfnre

{mf »

-
=
g
e
a
jw)
@
-t
w

Of=s
/T
=
%
74

Wal ID

Walt ]

Walll

,_.
>
o' a

P
=
g'e
[w]
B &

3-Z-force

4-MNormal Force

pd

File loaded

E:\LSPP_trainingy2015\WORKSHO

Al

Multiple Select

Clear Re@
@ Main

D":‘i || Padd || New |
| Cear || Raise || Pop |

Done

XY-Plot Page Manager | X |

Name Untitled D

Page Tree List

=B Pagel:Untitled i
NP0 | 1
.7 portz|  Delete
‘| Portzl  Control
S Create new page
RDWC Cancel
Background

‘ Save H Load H Print ‘

Show Port H Delete All ‘

-

XY-Plot Port Control [=3 |
Page 1:Untitled Port 1 [ set as master
Grid Curve list
Tick

Frame
Legend
Autofit

Timeline @
[ Invert Apply
[ Maxgragh

[ Maxmin m
/{% SR = H 2
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Cut a section plane...

Workshop 6 (continued...)

» Rotate the model for an isometric view
» Go to Model - Section Plane

» Click NormX
» Click Cut
= Click Options

» Select Line Width: 3
» Click Animate Forward

» Click MP Anim

= Click MP Anim again stop the animation
= Click Stop Animation

LS-PrePost Intro | 2016

Section Plane @
@Fxs (FxM () Lagr
@ 1p+NL () N1-N2
() 3Nds () 2Nds+D
BasePt [ |BaseNd

Xz 396.000000
Y: 101.599998
7 24.000000
[l

MormX || NormY || NormZ
1 0 0

|Centroid|| G || Reset |

Model Selection

Move Plane
Base Pt. Location:
396.000( 101.599¢ 24,0000

MP Anim|[ # || i Kpsc |

L

[T] Sect Vector

|:| Kp Cuts
2 A Cut “Dption Crush l

—

Model || Meas || Lie |

l Force “ Save “ Done |.:5
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Take section plane measurements...

LS-PrePost Intro | 2016

Click Model in Section Plane

Click Normz

Click Cut

Click Project View in Section Plane

Click Meas in section plane(NOT Measur)
Select 2Ln-Angle

Click two points to form a line on the left top
Click two points to form a line on the right top
Click Options

Activate ShMesh (section plane as a mesh)
Click Curr State

Click Write to save the section data
(writes keyword file with beam elements only)

Click Done in Section Plane interface

Angle=5.8573

_.---\_
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Workshop 6 (continued...)

Output dynain file...

LS-PrePost Intro | 2016

Go to Post - Output

Select Format: Dynain ASCII

In the animation controls, advance to the last state
Click Curr (current state)

Click Write
(writes a dynain ASCII file that contains stress, strain,
and thickness information)

Output U &
Format: |Dynain ASCIT -

@) Active Parts Only
Entire Model

Int. ID @) User ID

Element

Modal Coordinates

Modal Displacement
Modal Velocities

Element Results

Modal Results

Shell P-Strain

Shell Thickness

Fluid Surface

Element Centroid, Volume
1 fle per part

Separation Vector
Exclude strain and stress
Solid ortho

Append St No: 12
Normalization:

Scale Factor: 1

©2016 Livermore Software Technology Corporation

| Write H Curr H Done |
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Workshop 6 (continued...)

Save LS-PrePost database (post.db)...

= |nthe animation controls, advance to the desired state
= Go to Model - Assembly and Part (SelPart)

= Select “1 LSHELL1” and “2 LSHELL2” only

=  Go to Element Tools - Blank

= Select Area in the General Selection interface
= Select Out

= Draw a box around a portion of the model

=  File > Save As > Save Post.db As...

» |nthe Save PostProcess DB interface, select the data
you want

» Click >>

= Enter afile name
(select /workshop6/post.db)

= Click Write DB

LS-PrePost Intro | 2016 ©2016 Livermore Software Technology Corporation



View multiple models...
= Launch a new session of LS-PrePost

= File > Open > LS-DYNA Binary Plot e
(select /workshop6/example2/d3plot), click Open ( P2 |1 >-55L. AD ELASTIC FLATE

= File > Open > LS-DYNA Binary Plot
(select /workshop6/elastic_plate/d3plot), click Open

= Click the Left render button

= Go to Model > MSelect

= Select Translate

= Select “2-BALL AND ELSTIC PLATE” from the list
= Activate Z only

=  Enter Trans Dist: 250.0

= Click the Left Arrow button

= Select Select

= Click and drag to select both items in the list

= Click the Auto Center (AutCen) render button
= Click the Hide Element (HidEle) render button
= Click Animate Forward

LS-PrePost Intro | 2016

Workshop 6 (continued...)

Maodel Sele

2

@) Select \:_I'/éompare

-._:,.-Select -.Q.-Translate
-._:,.-Remm.re -.,:_.-lnﬁ:u

®

odel Selection £
5-)elect Compare

.Q.-Select -.,:_.-Translate
-._:,.-Remm.re -.,:_.-lnﬁ:u

1-L5-DYNA KEYWORD DECK BY
2-BALL AND ELASTIC PLATE

Cx Cly

Trans Dist:

¥z

250

l All “ Mone “ Rev ]

0 Sync largest state
Sync smallest state

Sync state

[ ] setactive
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Workshop 6 (continued...)

Create a cross plot...

Launch a new session of LS-PrePost

File > Open > LS-DYNA Binary Plot
(select /workshop6/elastic_plate/d3plot), click Open

10

I5F PlotWindow-1 (=B -
14 BALL AND ELASTIC PLATE
i /\ Contact Id
12 A
¥ A SI2

\

\

Go to Post > ASCII s [ s
Select “rcforc *” N ol / \
Click Load N \
Select “SI-2” from the middle list 0l o \4 .
Select “Z-force” from the lower list ’ ] ) ﬂmeE 8
Click Plot - | omctan fms  smes | s ]2
Click Scale in PlotWindow-1 e L T Frarme
Enter Y-scale: -1 @ osers X-scale 1 qﬁﬂ?p
Click Apply " otieo V-scae 1 et
Activate Autofit et et wetr | ot | e | oo [0
Click Save enter Filename: force_vs_time.crv
Click Save in the bottom row of buttons
Click Quit in PlotWindow-1
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Workshop 6 (continued...)

Create a cross plot (continued)...
= Goto Post - XYPlot

= Click Add
(select /workshop6/elastic_plat

= Select Cross
= Select X-Axis
= Select “disp_vs_time.crv” in file

e/disp_vs_time.crv)

= Click “disp_vs_time.crv:2060” in Curve Names

= Select Y-Axis

i | PlotWindow-1 ==

= Select “force_vs_time.crv”
in file

= Click “force_vs_time.crv:S| 2”

in Curve Names

Click Plot

BALL AND ELASTIC PLATE

Contact Id

121 /}‘ A 2060
10

Z-force
(=]
Y

2 VV

L | ﬁﬁé% ‘

0 5 10 15
Z-displacement

SRS | Title | Scale ‘ Attr | Filter ‘ Print ‘ Save | Load ‘ Oper | Hide | Close ‘ Quit

XY Plot <

0 File -._:,.-Window

force_vs_time.crv

disp_vs_time.crv

Y

et

| Add ||Remove|| mfo )

(@) X-Ais () v-ods

’X: disp_vs_time.crv:1:2060
Y : force_vs_time.crv:1:Sl 2(
[ | Auto match and clip

[] mterpolate 1000

Curve Names:

force_vs_time.crv:1:5Sl 2(np=

Curve Mame Filter:

0 Fopup -._:,.-Main

) Plot || wew || Padd |

[ dlear || ase |[_rop ]

Show 0 Cross K 2

Done
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Workshop 6 (continued...)

Set a reference point...
= Launch a new session of LS-PrePost

= File > Open > LS-DYNA Binary Plot
(select /workshop6/belted/d3plot), click Open

= Click the Left render buttons

= Click Animate Forward

= Click Stop Animation

= Go to Post - Follow

= Pick any node on the structure
= Click Apply

» Click Animate Forward

= Click Reset (in the Follow interface)

= Click Done (in the Follow interface)
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Workshop 6 (continued...)

View velocity vectors...

Go to Post - Vector
Select Velocity from the drop down menu
Click Apply

Click Next State (in the animation interface) to step
through the animation frame by frame

Click Done

LS-PrePost Intro | 2016 ©2016 Livermore Software Technology Corporation

Vector Plot 22
"u’elocit‘,r - l
51 52 53

[V]x V] ¥z

Vector Range

Min: 0
Max: ]
(@) Dynamic () static
() user () Show
SF:| 1.0 - 1.0

|| Hidden line vector off
I | keep vector display
|| pisplay highlighted node vel.

@ Whale (") Part
) Area I ElfMNode

Apply | Clear || Done |

2\
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Workshop 6 (continued...)

Colors, Groups, and Views...
= Go to Model = Part Color

= Click Lmap
(select /workshop6/colors_groups_views/colors)

= Go to Model < Groups

= Click Load
(select /workshop6/colors_groups_views/groups)

= Select “dummy” from the list
= Click Select

» Go to Model = Views

= Click Load
(select /workshop6/colors_groups_views/views)

= Select “View_01" from the list
= Click Select
= Click Done
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